华为S5700三层交换机基本配置

通过Console口登录交换机

 通过Console口登录主要用于交换机第一次上电或者本地配置。或者无法通过远程访问时,可通过Console口登录。

    如何才能通过Console口登录交换机呢?在配置通过Console口配置交换机之前,需要完成以下任务:

  • 准备好PC/终端(COM串口 和 RS-232电缆

  • PC已安装终端仿真程序(超级终端、SecureCRT、Xshell等

 

    使用配置电缆将PC的9芯串口(串口标志是COM)插座,(如果没有COM口,可以使用USB转RS-232连接)和交换机的Console口连接,然后把交换机上电。然后通过终端软件连接,设置连接的接口以及通信参数。

    现在很多笔记本都没有com口了,所以最好需要一根 USB 转 RS232 线(在下给各位大神推荐 力特 品牌,相当给力)就更完美了。

wKioL1WKB0TRiWZKAABmEknY-fY018.jpg

wKiom1VRwa_Sz7bcAAA57sRVrjE010.jpg

wKiom1SBZ2HArUAuAAG5uczoX0g009.jpg

    这里我当时遇到的问题是:Port 应该选择COM* 呢? 因PC端可能会存在多个连接接口, 这里需要选择的是连接Console线缆的那个接口。 一般情况下, 选择的接口是COM1。

    这个端口号,我们可以在【设备管理器】中查看,并且可以更改端口的编号。方法如下:

设备管理器 --- 端口(COM和LPT)【只有连接到串口线才会出现】--- 双击要修改的COM口(或者右键-属性)-- 端口设置 -- 高级 --端口号

wKioL1SBaOGhKPOiAAJAEyFVkhU669.jpg

 

 


OK, 登录到交换机之后,就开始配置吧。以下配置中绿色字体是需要自定义的


## 命令是不区分大小写的 ##

# 设置设备的名称为GSH-FZ-Front
<Quidway> system-view
[Quidway] sysname GSH-FZ-Front

 

# 设置查看设备的时区,时间

# 设置当前时间:clock datetime HH:MM:SS YYYY-MM-DD

# 设置时区: clock timezone time-zone-name { add | minus } offset
# 注意这里是 <用户> 视图

<Quidway> clock timezone BJ add 8
<Quidway> clock datetime 18:20:30 2011-06-08
<Quidway> display clock

 

#作为ntp客户端:设定NTP服务器,自动获取更新时间,假设NTP服务器为 202.120.2.101,202.112.10.36

<Quidway> system-view
[Quidway] ntp-service unicast-peer 202.120.2.101

[Quidway] ntp-service unicast-peer 202.112.10.36

 

# 作为ntp服务器:配置S5700为内网的NTP服务器内网的二层交换机指定这个S57为 NTP server 就行

<Quidway> system-view

[Quidway] ntp-service authentication enable
[Quidway] ntp-service sync-interval 180
[Quidway] ntp-service authentication-keyid 42 authentication-mode md5 cipher 123456
[Quidway] ntp-service reliable authentication-keyid 42

# 查看NTP状态

<Quidway> display clock

<Quidway> display ntp-service status

<Quidway> display ntp-service sessions

 

# 设置标题文本

<Quidway> system-view

# 设置登录时的提示信息: header login { information text | file file-name }

[Quidway]  header login information #Welcome S5700#

# 设置登录成功后的提示信息: header shell { information text | file file-name }

 [Quidway] header shell information #Welcome S5700#

注意:输完命令header shell information后,需要敲一个特殊字符,什么符号都可以,比如“%”,然后回车进入“shell' information”的输入界面,此时可以随意输入任何字符,最后一定要以我们刚才设定的符号结束(这里是 “%”),然后回车退出此界面,方可生效。

注意:这条命令Header后面有两个参数,一个是shell,一个是login,shell是进入命令行时(<Quidway>)的提示信息,login是成功登录设备之后看到的提示信息。

 

#telnet远程登录

前提:

1、交换机以太网接口的IP地址

2、Telnet 访问的用户信息(用户名、口令和验证方式)

3、保证PC与交换机路由可达

 

有些盒式设备没有管理口,可使用VLANIF接口配置管理IP地址。

步骤一:创建VLAN,并配置交换机VLAN的管理IP

#  创建vlan

<Quidway> system-view

[Quidway] vlan 10

[Quidway-vlan10] quit  

 

# 配置管理 IP

[Quidway] interface vlan 10

[Quidway-Vlanif10] ip address 192.168.1.2  24      【或  ip   addr  192.168.1.2  255.255.255.0】

[Quidway-Vlanif10] quit

# 把端口加入vlan

[Quidway] int gigabitethernet 0/0/1
[Quidway-GigabitEthernet0/0/1] port hybrid untagged vlan 10     (0/0/1端口以untag方式加入vlan 10)

[Quidway-GigabitEthernet0/0/1] quit

 

步骤二:配置telnet用户,登录级别和认证方式. 在交换机上配置Telnet服务功能并使用AAA验证方式登录。

# password { simple | cipher }

# 如果使用simple选项,密码将以明文形式保存在配置文件中。一般情况下,应使用cipher 选项将密码加密保存,同时使用

# cipher选项后,无法从系统中取回,请妥善保管密码。
<Quidway> system-view
[Quidway] aaa
[Quidway-aaa] local-user testadmin password cipher p@ssw0rd privilege level 15

[Quidway-aaa] local-user testadmin service-type telnet        (设置用户登录方式为 telnet, 只能通过telnet方式登录,还有这几种 ssh   http   web)  一般不配置它。

[Quidway-aaa] quit

 

[Quidwaytelnet server enable

[Quidway] user-interface vty 0 4

[Server-ui-vty0-4] user privilege level 15

[Quidway-vty0-4] authentication-mode aaa        (设置认证方式为: aaa )

[Quidway-vty0-4] quit

 

小贴士: 如果采用eNSP做实验,验证telnet 配置。 使用PC是不行的。 可以用 AR 模拟代替PC, 需在用户模式下使用 telnet 命令。

 

#SSH远程登录

需求:PC能通过SSH协议远程登录交换机进行管理。

1、生成本地密钥对:

<Quidway> system-view
[Quidway] rsa local-key-pair create

The key name will be: Auotnavi-callcenter-01_Host

The range of public key size is (512 ~ 2048).

NOTES: If the key modulus is greater than 512,

       It will take a few minutes.

Input the bits in the modulus[default = 512]:1024

Generating keys...

.++++++

............++++++

...............++++++++

.++++++++

2、配置VTY用户界面

<Quidway> system-view
[Quidway] user-interface vty 0 4

[Quidway-ui-vty0-4]  authentication-mode aaa

# 必须设置VTY用户验证方式为AAA,否则 protocol inbound ssh 命令无法成功

[Quidway-ui-vty0-4]  protocol inbound ssh

3、创建SSH用户及密码

[Quidway] aaa

[Quidway-aaa] local-user admin password cipher 123

[Quidway-aaa] local-user admin privilege level 15

[Quidway-aaa] local-user admin service-type ssh

4、使用Stelnet,并配置SSH用户的认证方式

[Quidway] stelnet server enable

[Quidway] ssh authentication-type default password



## 划分VLAN

默认情况下,所有交换机端口都属于vlan1

#创建VLAN
<Quidway> system-view                    (一般缩写为:sys)

[Quidway] vlan 10                               (批量添加vlan:  vlan batch 10 20 30;    vlan batch  2  3  to  10)
[Quidway-vlan10] quit                         (一般缩写为:q)

[Quidway]display vlan                         (查看创建的VLAN)

#设定端口模式,默认为trunk,需要将端口划入VLAN之前,先把端口类型转为 access

<Quidway> system-view                    
[Quidway] int gigabitethernet 0/0/1                    (进入端口配置模式: interface)
[Quidway-GigabitEthernet0/0/1] port   link-type  access

[Quidway-GigabitEthernet0/0/1] port   default  vlan 10    # 将端口加入vlan

 

[Quidway-GigabitEthernet0/0/1] dis this

#

interface GigabitEthernet0/0/1

 port link-type access

 port default vlan 10

#

return

[Quidway-GigabitEthernet0/0/1] quit

 

#将端口加入Vlan(第二种方式)
<Quidway> system-view
[Quidway] vlan 10
[Quidway-vlan131] port gigabitethernet 0/0/1      (连续多个端口,用 xx to xx, 如:port giga 0/0/5  to  0/0/10)
[Quidway-Vlan131] quit

 

#设置Trunk, 两台相连的交换机都要设置
<Quidway> system-view
[Quidway] interface GigabitEthernet 0/0/23
[Quidway-GigabitEthernet0/0/23] port link-type trunk
# 如果不设置下面这条配置,VLAN10 , VLAN131都会处于DOWN的状态

[Quidway-GigabitEthernet0/0/23] port trunk allow-pass vlan 10 131    (多个VLAN列出,允许哪些VLAN通过)

 

#设置VLAN IP(管理IP)

VLANIF 接口

当需要与网络层的其他设备通信时,可以创建基于VLAN的逻辑接口,即VLANIF接口。VLANIF接口是网络层接口,可以配置IP地址,借助VLANIF接口,就能与其他网络层的设备相互通信。

<Quidway> system-view

[Quidway] interface vlanif 131
[Quidway-Vlanif131] ip address 192.168.0.253 255.255.255.0  (缩写: ip add  IP  MASK)
[Quidway-Vlanif131] shutdown
[Quidway-Vlanif131] undo shutdown

 

# 删除VLAN

1、如果配置VLAN的管理IP,在系统视图下,使用 undo int  vlan 10 命令删除VLAN 10的3层虚拟接口,这样三层的VLAN 10就被删除了,但是划入VLAN 10 的那些端口依然在VLAN 10中。这时还需要把那些端口恢复,让他们不属于任何VLAN

<Quidway> system-view
[Quidway] undo int vlanif 10

2、在系统视图下,使用 undo vlan 10 命令可以删除2层接口,这个命令可以释放那些原来划分为VLAN 10的端口,现在这些端口就属于默认的VLAN 1了。

<Quidway> system-view
[Quidway] undo vlan 10

[Quidway] display vlan

当然,要向VLAN添加端口,是可以直接在VLAN视图中添加的。


需要注意的是:交换机上的某个端口被设置成access模式,且加入了一个VLAN, 要想将这个端口模式改为trunk,直接在接口视图中“port link-type trunk” 是不行的,会出现 Error: Please renew the default configurations. 这时需要先从VLAN中删除这个端口,也就是让这个接口恢复到默认的VLAN 1, 才能将这个端口设置为trunk。

<Quidway> system-view
[Quidway] vlan 10

[Quidway] undo port giga 0/0/1


1、批量创建VLAN

< Huawei > system-view

[Huawei]vlan batch 2 to 100

2、批量端口加入VLAN

[Huawei] port-group group-member GigabitEthernet 0/0/10 to GigabitEthernet 0/0/20

[Huawei-port-group]port link-type access

[Huawei-port-group]port default vlan 100

3快速恢复端口VLAN缺省配置

想要快速恢复端口VLAN的缺省配置,必须要知道什么是缺省配置?华为交换机,缺省情况下所有端口都是只加入VLAN1的。

那么下面和小编一起看看3种链路类型下,怎么快速恢复缺省配置呢?

 access口: 一步搞定,命令是undo port default vlan

 trunkhybrid口: 三步搞定,先恢复PVID的配置,再删除端口下所有vlan,然后再把缺省的VLAN1 加入。具体命令如下:

wKiom1Z_RUCABcMhAAA6M0AYgl0364.png


# 配置端口组, 进行批量配置

# S5700有48个端口,如果要配置VLAN,需要为每个端口先配置port link-type access,才能加入到VLAN,这岂不是很郁闷?

如此多的接口,要是我一个个逐一配置多麻烦啊。不仅容易出错,而且造成大量重复工作。  【配置端口组功能就可以解决该问题】

# 于是乎,端口组的出现了,把一些端口添加到一个组里,然后对这个组进行配置,该组内的所有端口都会应用此配置,这样就能批量配置了,大大减少重复工作。

你只需要将这些以太网接口加入同一个端口组,在端口组视图下,只需输入一次业务命令,该端口组内的所有以太网接口都会配置该命令,快速完成接口批量配置,减少重复工作。

其实端口组也是有临时端口组和永久端口组两种。

临时端口组:一旦退出端口组视图,该临时端口组将被系统自动删除。

永久端口组:将写入配置文件,如果希望删除永久端口组,需要手动删除。

 

配置临时端口组:

需求:需要将GE0/0/1GE0/0/10共二十个接口均关闭,但是后续这些接口由于配置不一致,还需要单独进行配置,那就可以选择临时端口组进行如下配置:

<HUAWEI> system-view                                             

[HUAWEI] port-group group-member gigabitethernet 0/0/1 to gigabitethernet 0/0/10  // 将接口GE0/0/1GE0/0/10加入到临时端口组,此步骤等同于执行命令interface range gigabitethernet 0/0/1 to gigabitethernet 0/0/10

[HUAWEI-port-group]shutdown        // 临时端口组视图中配置需要批量下发的命令         

[HUAWEI-port-group] quit       // 退出临时端口组后,系统就会自动删除这个临时端口组


配置永久端口组

需求:需要将GE2/0/1GE2/0/10共十个接口均配置为access接口,而且这些接口配置信息相对固定,均保持一致,那就可以选择永久端口组进行如下配置:

<HUAWEI> system-view                                              

 

[HUAWEIport-group portgroup1                         // 创建名称为portgroup1的永久端口组 

[HUAWEI-port-group-portgroup1] group-member gigabitethernet2/0/1  to  gigabitethernet  2/0/10
                         //  将接口GE2/0/1~GE2/0/10加入到永久端口组中

[HUAWEI-port-group-portgroup1] port link-type  access 

                         // 永久端口组视图中配置需要批量下发的命令                                      

[HUAWEI-port-group-portgroup1] quit                            // 退出端口组视图后,名称portgroup1的永久端口组仍然存在

江湖小贴士:如何知道永久端口组中的成员接口呢?

执行命令display port-group [ all | port-group-name ],就可以查看永久端口组的成员接口信息啦。


如何批量清除一个接口的所有配置?

只需要在接口视图下执行命令clear configuration this就可以一键清除接口下的配置啦。

 

[HUAWEI] interface gigabitethernet 0/0/1
[HUAWEI-GigabitEthernet0/0/1]
#
interface GigabitEthernet0/0/1
description switch-A
port link-type access
#
return
[HUAWEI-GigabitEthernet0/0/1] clear configuration this       // 清除接口下所有配置,恢复到缺省值
Warning: All configurations of the interface will be cleared,and its state will be shutdown. Continue? [Y/N] :y
Info: Total 2 command(s) executed, 2 successful, 0 failed.
[HUAWEI-GigabitEthernet0/0/1] display this
#
interface GigabitEthernet0/0/1
shutdown // 清除接口下所有配置后,接口将处于关闭状态
#


为何我在华为的模拟器5700交换机上无法使用 clear configuration this 命令,交换机版本是 Version 5.110 (S5700 V200R001C00) ??

 

交换机V2R1版本不支持clear configuration this 命令,对于V2R1版本,您可以在系统视图下执行如下命令

一键式清除接口下的配置---   [Quidway]   clear  configuration  interface  interface-type  interface-number


1、命令注释建议使用 # 空格+注释,不要使用 // ,因为 # 加空格的注释直接拷贝到设备上也不会提示错误~
2、注释建议另起一行(如命令行前面),不要直接跟在命令后,导致一行过长,换行看着比较乱


<Quidway> system-view
[Quidway] port-group 1      # 创建名为1的永久端口组

[Quidway-port-group-1] group-member GigabitEthernet 0/0/10 to GigabitEthernet 0/0/20   # 添加端口到组

# 然后就可以批量设置端口了

[Quidway-port-group-1] port link-type access            # 设置端口类型

[Quidway-port-group-1] port default vlan 10             # 把端口加入vlan

# 查看组配置

[Quidway] display cur | include group

 

对端口进行限速

    假设对交换机的第2个端口进行限速,让通过这个端口的下载速度不超过 128KB/S

Inbound:     入端口的流量限速

Outbound:   出端口的流量限速

<Quidway> system-view

[Quidway] int giga 0/0/2

[Quidway-GigabitEthernet0/0/2] qos lr outbound cir 1024 cbs 204800 

# 默认单位:KB, 1024表示1M的带宽,理论下载速度就是 128KB/S, cbs代表突发信息速率,cir表示承诺信息速率

# 取消限速

[Quidway-GigabitEthernet0/0/2] undo qos lr outbound 

 

配置基于地址池的DHCP服务器

1、全局启用DHCP服务

<Quidway> system-view

[Quidway] dhcp enable

 

2、创建地址池并配置相关属性。配置IP地址池 10 的属性(地址池范围、DNS地址、出口网关、租期)

[Quidway] ip pool 10

[Quidway-ip-pool-10] network 192.168.10.0 mask 255.255.255.0

[Quidway-ip-pool-10] excluded-ip-address 192.168.10.250 192.168.10.254  (start_ip - end_ip)

[Quidway-ip-pool-10] dns-list 202.103.24.68

[Quidway-ip-pool-10] gateway-list 192.168.10.1

[Quidway-ip-pool-10] lease day 10

[Quidway-ip-pool-10] quit

同样, 也可以配置地址池 20 的属性。(地址池范围、DNS地址、出口网关、租期)


2、配置VLANIF 10 接口下的客户端从全局地址池中获取IP地址

 

[Quidway] interface vlanif 10

[Quidway-Vlanif10] ip add 192.168.10.1 255.255.255.0    (或者 ip add 192.168.10.1  24)

[Quidway-Vlanif10] dhcp select global

[Quidway-Vlanif10] quit

更多内容:http://www.elvhome.com/html/2013-5-15/201351511175895517.html

 

#设置默认路由
<Quidway> system-view
[Quidway] ip route-static 0.0.0.0 0.0.0.0 192.168.0.254

 

# 关闭WEB Server,dhcp
<Quidway> system-view
[Quidway] undo http server enable
[Quidway] undo dhcp enable

 

## 用户管理

用户登录界面

  • CON     适用于从Console接口进行本地登录

  • VTY      适用于Telnet或SSH方式进行本地或远程登录,是虚拟接口。当用户以telnet, ssh, ftp 方式登录到交换机,就建立了一条VTY连接。

用户验证

    对于登录到S5700的用户,系统需要根据配置对其进行验证以保证系统的安全性。

用户级别

    用户分为多个级别,标识越高则优先级越高。如果不对用户进行优先级规划,默认用户登录级别为 0 - 3 级。

用户所能访问命令的级别由用户的级别决定

  • 如果对用户采用不验证或者password验证,登录到S5700的用户所能访问的命令级别由登录时的用户级别决定

  • 如果对用户采用AAA验证,登录到S5700的用户所能访问的命令级别由AAA配置信息中本地用户的级别决定

登录用户划分为16级,与命令级别对应。不同级别的用户登录后,只能使用等于或低于自己级别的命令。用户所能访问的命令包括用户所在用户级别的命令以及低于此用户级别的命令。

验证用户的方式:

wKioL1SQDmmB2a2PAACHNza34OY058.jpg

wKiom1Wgw13DMO0tAAWacQW-bEg063.jpg    

系统提供AAA本地验证、密码验证和不验证三种方式。 如何配置启用哪种验证方式呢?

<Quidway> system-view

# user-interface 配置用户接口
[Quidway] user-interface [ui-type] first-ui-number [last-ui-number]

# 配置启用用户验证方式

[Quidway] authentication-mode { aaa | password | none }

super密码:

    华为super 命令设置的口令用于低级用户向高级别用户切换时进行验证,类似于Linux系统从普通用户切换到root用户时需要验证。用户共分为4级,分别是访问级(0)、监控级(1)、系统级(2)和管理级(3),当低级别的用户向高级别的用户身份切换时: super [level] , 此时只有验证通过后才能切换成功。可以通过super命令提升用户级别。

    如果使用 simple 选项,密码将以明文形式保存在配置文件中,以低级别登录的用户可以通过查看配置方式获取切换密码,造成安全问题。因此,应使用cipher 选项,将密码加密保存。

配置实例:

    1、配置console口为密码验证方式

<Quidway> system-view
[Quidway] user-interface console 0

[Quidway-ui-console0] idle-timeout 0  0   ( idle-timeout minutes [seconds] )

[Quidway-ui-console0] history-command max-size 100

# 配置用户级别

[Quidway-ui-console0] user privilege level 3        # 设置此接口登录的用户级别

# 配置验证方式  password

[Quidway-ui-console0] authentication-mode  password 

[Quidway-ui-console0] set authentication password { cipher | simple } password


    2、配置VTY虚拟接口使用3a认证

    配置VTY 0-4, 优先级为2, 对从VTY 0-4登录的用户进行AAA验证,用户登录时需要输入用户名: huawei, 密码:huawei

登录后,如果用户超过30分钟未对交换机进行操作,将断开与交换机的连接。

# 第一步:配置接口的验证方式

<Quidway> system-view

[Quidway] user-interface maximum-vty 5        配置可以同时登录交换机的VTY最大个数

[Quidway] user-interface vty 0 4

[Quidway-ui-vty0-4] authentication-mode aaa

[Quidway-ui-vty0-4] user privilege level 2

# 这里的用户级别设置为2 , 但是采用AAA验证,那么级别由AAA中的本地用户级别决定。 如果采用password或者不验证,那么从此接口登录的用户就是 level 2 级别的。

[Quidway-ui-vty0-4] idle-timeout 30    (idle-timeout minutes [seconds])

[Quidway-ui-vty0-4] quit

# 第二步:配置AAA用户,密码以及权限

[Quidway] aaa

[Quidway-aaa] local-user huawei password cipher huawei 

# 下面service-type一般不用配置, 将允许所有类型

[Quidway-aaa] local-user huawei service-type telnet

[Quidway-aaa] local-user huawei privilege level 15

[Quidway-aaa] quit

# 第三步:配置supper密码

[Quidway] super password level 3 cipher huawei

#保存配置
<Quidway> save

 

# 配置FTP

1、创建vlan

<Quidway> system-view

[Quidway] vlan 10

2、将端口划入vlan

[Quidway-vlan10] port GigabitEthernet 0/0/1 to 0/0/4            (注意:划入的端口模式必须为access)

[Quidway-vlan10] quit

3、配置vlan的管理IP

[Quidway] int vlanif 10

[Quidway-Vlanif10] ip add 192.168.1.254 255.255.255.0

[Quidway-Vlanif10] quit

4、添加FTP用户

[Quidway] aaa

[Quidway-aaa] local-user huawei password cipher huawei privilege level 15

[Quidway-aaa] local-user huawei service-type ftp                # 配置用户为ftp登录

[Quidway-aaa] local-user huawei ftp-directory flash:/          # 配置登录的FTP目录

[Quidway-aaa] quit

5、开启ftp服务

# 配置ftp服务器超时断开的时间

[Quidway] ftp timeout 30        # 单位 minutes

# 默认情况下,交换机是没有开启ftp服务的,需要手动打开

[Quidway] ftp server enable

# 使用display ftp-server 命令查看ftp服务器的配置和状态信息

[Quidway] display ftp-server

6、可选:配置ACL基本访问控制列表

# 配置ACL规则

[Quidway] acl number 2001

[Quidway-acl-basic-2001] rule permit source 192.168.1.10 0.0.0.0 

[Quidway-acl-basic-2001] quit

# 把acl规则应用到ftp

[Quidway] ftp acl 2001

7、连接测试

# 打开命令提示符,或者其他ftp工具

C:\Users\admin> ftp 192.168.1.254

Connected to 192.168.1.254

220 FTP servece ready.

User(192.168.1.254(none)):huawei

331 Password required for huawei.

Password:

230 User logged in.

ftp> 

 

# 配置WEB

1、上传web文件

# 注意:要开启web服务,需要先上传web管理文件(xxx.web.zip) 到交换机的根目录下

# 可以通过ftp上传

C:\Users\admin> ftp 192.168.1.254

ftp> put xxx.web.zip 

2、开启web服务

<Quidway> system-view

[Quidway] http server load flash:/xxx.web.zip

[Quidway] http server enable

3、配置web用户

[Quidway] aaa

[Quidway-aaa] local-user webadmin password cipher webadmin

[Quidway-aaa] local-user webadmin service-type http

[Quidway-aaa] quit

4、通过浏览器测试

URL 地址: http://192.168.1.254

 

#相关查看命令
[Quidway] display version         显示VRP版本号,以及运行时间

[Quidway] display cpu-usage         显示CPU信息

[Quidway] display memory-usage              显示内存占用情况

[Quidway] display device                          显示设备信息


[Quidway] display current-configuration     显示系统运行配置信息
[Quidway] display saved-configuration       显示保存的配置信息
[Quidway] display interfaces brief             显示接口配置信息

[Quidway] display history-command          显示历史命令记录

[Quidway-GigabitEthernet0/0/1] display this     显示该接口的所有配置     

 


接口视图: interface

 display interface [ interface-type [ interface-number ] ] # 查看二层信息

 display interface brief

 display ip interface [ interface-type interface-number ] # 查看三层信息

 display ip interface brief [ interface-type interface-number ] 

 


# 管道过滤

[Quidway] display xxx | { include | exclude | begin }  strings   

# 当出现 -- More -- 时,同样支持

  • /expr        == begin

  • -expr        == exclude

  • +expr       == include 

[Quidway] display current-configuration | include ntp

[Quidway] display current-configuration | include ip|user

# 注意第一个 | 是管道, 那么之后的 | 都不认为是管道,而是正则表达式的运算符

# 命令是不区分大小写的,但是 strings 是区分的。


总结一下:

对于一台全新的交换机,我们首先要确定用来做什么?(业务规划),然后结合已有的网络拓扑情况。

能够对其进行如下几个方面的设定:

  • 系统管理

  • 接口管理(逻辑接口,物理接口,user-interface ...)

  • 业务管理(DHCP, STP, VRRP ...)

  • ACL

  • 路由管理(优先级,动态,静态)

  • 安全管理


配置实例:

实验拓扑如下图所示

wKiom1Rup82jEOVrAAFhQNaDtl4883.jpg

规划:

路由器LAN: 192.168.100.2 / 30

VLAN100:192.168.100.1 / 30

VLAN10: 192.168.10.1 / 24

VLAN20:192.168.20.1 / 24

 

路由器上需要配置回程路由:

192.168.0.0 255.255.0.0  192.168.100.1

汇聚交换机:将GE0/0/3作为连接路由器的端口,GE0/0/1到GE0/0/2分别和2个接入层交换机相连,剩余端口全部shutdown,以后扩展时在启用。

 

接入层交换机无需配置,即插即用。

1
2
3
4
5
6
7
8
9
10
11
12
13
三层交换机 SW1 配置:
<Huawei>sys
[Huawei]vlan bat 10 20 100    # 批量添加vlan 10 和 20
[Huawei]int g0/0/1
[Huawei-GigabitEthernet0/0/1]port link-type trunk
[Huawei-GigabitEthernet0/0/1]port trunk allow-pass vlan 1 10 20
[Huawei-GigabitEthernet0/0/1]dis this
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
return

 

eNSP小贴士:

使用SecureCRT 登录eNSP模拟器

  • eNSP(Enterprise Network SimulationPlatform)是一款由华为提供的免费的、可扩展的、图形化操作的网络仿真工具平台,主要对企业网路由器、交换机进行软件仿真,完美呈现真实设备实景,支持大型网络模拟,让广大用户有机会在没有真实设备的情况下能够模拟演练,学习网络技术。

  • SecureCRT是一款支持SSH的终端仿真程序,简单的说是Windows下登录UNIX或Linux服务器主机的软件。不同就是SecureCRT支持SSH,同时支持Telnet和rlogin协议。SecureCRT是一款用于连接运行包括Windows、UNIX和VMS的理想工具。

 

下面介绍用SecureCRT登陆eNSP设备的方法

1、  准备工作(查看IP 以及 相应设备的COM号)

注:此处Hostname为eNSP软件的本地服务器IP,Port为设备的eNSP软件设备列表中相应设备的COM号, 如何查看? 

(1)、查找eNSP的本地服务器IP:设置 —>选项框里选择服务器设置。

(2)、查看设备端口号:

首先点击eNSP主界面的【菜单】 - 【视图】 - 【工具栏】 - 勾选【右工具栏】;  或者直接 Ctrl  +  R 调出右工具栏。

wKioL1Z-j_ri7cmSAAC15DbHrIQ576.png

此时右侧弹出一个列表,在接口列表中查看设备端口号。在eNSP软件的接口视图中,会在设备名称后面显示一个端口号,这个端口号就是我们使用第三方工具时需要设置的端口号!

wKioL1Z-kRWQRT76AACENIyDOAE785.png

1、  打开SecureCRT,新建会话 -> 协议选择telnet ,单击下一步。   

2、  填写主机名和端口号,单击下一步。

wKiom1Z-lMuDuHjbAABBNmH3vL8246.png

注:端口号即为eNSP软件中接口列表中显示的数字。

3、输入设备名,单击完成。  设置成功后, 进行连接。 按 Enter 即可登录成功。

额外设置

4、  接下来,在使用时会有乱码情况出现,我们还需要对SecureCRT进行一下简单的设置:

打开SecureCRT软件,选项(options)->会话选项(Sessionl Options)->连接(connection)->Telnet->强制每次一个字符模式

5、  如果您在使用过程中还是会出现乱码,可以尝试设置仿真终端为"VT100"

http://support.huawei.com/ecommunity/bbs/10142395.html

Xshell: 

wKiom1Z-lTbQmo4uAAAjkLh2x10779.png

 

 

eNSP 使用问题汇总: http://support.huawei.com/ecommunity/bbs/10171461.html

 

 

 

 

 

上一篇:高效运维最佳实践七字诀,不再憋屈的运维!下一篇:返回列表